Issues with audio using the Online Creator

J's JunctionJ's Junction IllinoisMember, PRO Posts: 79

Is there a current bug for the sounds using the online creator? Month ago it worked fine. Audio using music or sound won't play. Thanks!

Answers

  • uptimistikuptimistik Member, Sous Chef, PRO Posts: 161

    Can you send a link to the game?

    GameSalad Templates and Custom Development at the Official Marketplace: http://gshelper.com

  • J's JunctionJ's Junction IllinoisMember, PRO Posts: 79

    I published and sounds work. Not sure why it won't work in preview.

  • uptimistikuptimistik Member, Sous Chef, PRO Posts: 161

    Hmm, try this:

    Right-click the preview tab, and if it says 'unmute site' the volume should return after clicking that.

    GameSalad Templates and Custom Development at the Official Marketplace: http://gshelper.com

  • J's JunctionJ's Junction IllinoisMember, PRO Posts: 79

    It was not muted. So that isn't it. Other browsers aren't working either.

  • J's JunctionJ's Junction IllinoisMember, PRO Posts: 79

    Other observations. Play music won't let me select any files. They are m4a. It use to allow it. I have to use Play Sound. I tried a different computer same results in preview

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,761
    edited January 23

    Yah, I see the bug now. Working on a fix but the root issue is mp4 is not technically a great file extension for audio.

    We tried to enforce m4a in the wrong place, and it breaks on projects that imported mp4 file since we put in the fix.

    If you DM the project link to to me (i.e. the creator.gamesalad.com link to the game), I can try to manually fix the files for now. We'll have a "real" fix soon.

  • adent42adent42 Key Master, Head Chef, Executive Chef, Member, PRO Posts: 2,761

    I'm not sure, but if you're on mac, sometimes Finder hides your file extensions so you think the file is .m4a but it may actually be .m4a.mp4. Right click on the the file and check "show extension"

  • ArmellineArmelline Member, PRO Posts: 5,214

    Only tangentally related, but also a sound bug so I'll mention it here. There is a sound bug in GameSalad that means setting "game.Audio.Sound Volume" to 0 doesn't actually do anything. 0.01 will set it to very quiet, but 0 will just do nothing. This is the case in Creator and in published games.

  • J's JunctionJ's Junction IllinoisMember, PRO Posts: 79

    @adent42 I sent it to you


    Thanks for all the help everyone!

Sign In or Register to comment.